Accesibillity

Home Forums Monument Valley Accesibillity

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #19393

    choulio19
    Participant

    Accesibillity

    Resolved

    Hi we talked through email about this

    I bought your template for accessibility purpose. Your work is awesome.

    I am working on dev inv.

    i check homepage with this tool
    https://achecker.ca/checker/index.php

    I get 2 errors. Is it possible to check it pls and help me? These 2 problems i can’t understand.
    Thanks

    This site is for one project. To pay the company this project the home page must be ok from accessibility test.

    They scan the site only from this site https://achecker.ca/checker/index.php

    I see 2 errors.
    The first is

    <h1 class="site-title site-title-text" itemprop="name">ortho</h1>
    

    and the second

    <input type="search" class="search-field" placeholder="Αναζήτηση&hellip;" value="" name="s" ...
    
    #19395

    Oliver Juhas
    Keymaster

    Hi choulio19,

    Please note that I’ve provided you with the solution in my reply to your email. For completeness here, is the reply copy:

    “Thank you, I’m glad you like the theme and thank you for contacting me. I’m sorry for the issues you experience visiting my support forum. Will do my best to resolve them so it is usable for you.

    I’ve checked your support forum account and indeed it seems Mailgun has problems delivering to your email address of giomaster1@hotmail.com either due to Outlook.com being on Mailgun’s block list or vice versa (I get error 550 5.7.1).
    I went ahead and reset your password. Please try to log in at https://support.webmandesign.eu/system/wp-login.php with these credentials:
    [ CREDENTIALS REMOVED ]
    You can then change the password at https://support.webmandesign.eu/forums/users/choulio19/edit/

    As for your issue, please note that AChecker is not a good tool for accessibility testing. You can see issues reported using this tool at https://support.webmandesign.eu/forums/search/?bbp_search=achecker

    Looking at AChecker validation report for your dev.patrasortho.gr website I can see it reports false positive for search form label, as usually… As you can see in the label is clearly there, and it’s not empty. So, you don’t have to do anything about this false positive.

    As for heading level issue, indeed, your website does not follow the good practice as the first heading level found after H1 (which is the website title on your homepage) is H3 (the “Δημ. Αθ. Παναγιωτόπουλος”). This should be H2.
    You can read more about good headings structure in theme documentation at https://webmandesign.github.io/docs/monument-valley/#accessibility and also in knowledge base article at https://support.webmandesign.eu/accessibility/ where you can also find information about how to test a website for accessibility issues.
    To resolve this issue please set the “Δημ. Αθ. Παναγιωτόπουλος” as H2. If you want to use H3 heading styling though, the theme allows you this by applying the custom h3 CSS class on the H2 heading HTML element. This can be even easily done using Formats dropdown button. Here is how to use Formats dropdown button to change the heading styling in Beaver Builder:

    custom-css-class-heading-style.png

    If you have any additional questions, please try submitting a support ticket (with login info I’ve provided above) or, if it still doesn’t work for you, please reply to this email.”

    To explain the heading issue, please understand that this is not a theme issue but your homepage content issue. Please read the above solution for how to fix.

    And as for search form label, please understand there is nothing to fix. The label is there, it’s just AChecker not picking it correctly. Please show your customer the proof I’ve provided in my email reply.

    Best regards,

    Oliver Juhas
    WebMan Design

    • This reply was modified 2 months, 1 week ago by  Oliver Juhas. Reason: Removing login credentials
    #19399

    Oliver Juhas
    Keymaster

    Also, please understand that search form HTML is coming from WordPress itself, not the theme. Here you can see how WordPress outputs the search form together with the label: https://developer.wordpress.org/reference/functions/get_search_form/

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.