Bevear Builder Global Module margin overriden by main.css of theme

Home Forums Polyclinic Bevear Builder Global Module margin overriden by main.css of theme

Viewing 10 posts - 1 through 10 (of 12 total)
  • Author
    Posts
  • #22107
    ckaklamanos
    Participant

    Bevear Builder Global Module margin overriden by main.css of theme

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    Hello.

    I am writing about the Polyclinic theme.

    Also, I am an experienced developer when it comes to Beaver Builder (this is why I bought the theme)

    My problem is that the Global setting of the Module margin is overridden by your main.css file. This is a negative surprise and has been very limiting for the way I build my project.

    I would never expect this BB setting to be overridden, right?

    Am I missing something? Could you please advise?

    Thanks.

    #22109
    Oliver Juhas
    Keymaster

    Hi ckaklamanos,

    Yes indeed, the theme sets Beaver Builder spacing differently from the plugin. The reason is to keep spacing OK with theme content width. Beaver Builder works a bit differently by default and it actually indent modules from the content width.

    However, thank you for spotting an issue, actually. It seems something has changed in one of previous Beaver Builder updates and setting custom module/row/column global margins/padding does not work properly anymore in the theme. I will do my best to fix this ASAP. Sorry for inconvenience caused.

    Best regards,

    Oliver Juhas
    WebMan Design

    #22110
    ckaklamanos
    Participant

    Hello, and thanks for the reply.

    Yeah, this needs fixing, because it felt very weird not being able to control those values via Beaver global options (by the way I always keep Beavers default values, because they make developing, at least for me, much easier.).

    Do you think you can fix this soon? I really need this to proceed with the project.

    Thanks.

    #22111
    Oliver Juhas
    Keymaster

    Hi ckaklamanos,

    I’ll do my best to release an update in next couple of days.

    But please note that it still might not work exactly as you expect it. Everything depends on your needs, actually, but like I’ve mentioned, the theme uses a different approach to layout than Beaver Builder.

    Anyway, this can be overridden via custom CSS still. So, if you want, you can try something like this:

    .fl-col-content {
    	padding: 0px;
    }
    .fl-module .fl-module-content {
    	margin: 20px;
    }

    But please note that thorough testing is required across multiple screen sizes.

    Best regards,

    Oliver Juhas
    WebMan Design

    #22121
    Oliver Juhas
    Keymaster

    Hi,

    I’ve just pushed a 1.9.3 version update of the theme which should fix the issues.

    Best regards,

    Oliver Juhas
    WebMan Design

    #22122
    ckaklamanos
    Participant

    Thank you very much for the update and for letting me know!

    #22173
    ckaklamanos
    Participant

    Hello

    I have updated with the new version, but I can still see the issue.

    For example:

    There is a BB module where I have left the default margin of 20px and it sitll has 0px padding.

    Am I missing something?

    Once again here is what I want to accomplish:

    I expect modules (and rows and columns) to keep the default values as they are setup via the BB Global settings.

    Please let me know.

    Thanks.

    #22175
    ckaklamanos
    Participant

    Hello, two more things:

    I am trying to apply:

    1. Left and right padding on a column via the BB settings and, again, the theme overrides this setting
    2. I am trying to equalize 2 columns and align their content in the middle (this is a standard BB feature) and, again, the theme will not let me do it.

    Please advice.

    I respect your work and your theme, but I have to say that this is disappointing.

    I really do not understand how did you decide to make such big intervention on how the Builder works (for the sake of the theme).

    The one and only reason that I bought this theme was because I work a lot with BB (and I like it very much as well).

    PS: I am a full-stack developer (not integrator) with 5 years of experience in WordPress development. I am not trying to be bad on you and your work, just trying to understand if the theme works as I expected.

    #22176
    Oliver Juhas
    Keymaster

    Hi ckaklamanos,

    Have you tried to flush the Beaver Builder cache?

    If the issue persist, could you please describe exactly a specific problem on a specific page of your website and provide admin access to your website so I can check personally?

    Like I’ve mentioned, the theme applies different styles than native Beaver Builder to keep the content within the theme’s content width theme option value. So, depending on your needs, you could not get the desired result still. But setting a global module margin should work as expected now.

    Rows should be fine as for global padding and margin.

    Columns get horizontal padding overridden by the theme due to spacing treatment described above.

    Modules get vertical margins overridden. This should be compensated with columns padding.

    I understand this might be confusing if you are used to default Beaver Builder behavior. But here is what I aimed to resolve in the theme:

    Beaver Builder inconsistent default spacing:

    Polyclinic Beaver Builder spacing fix:

    Best regards,

    Oliver Juhas
    WebMan Design

    #22177
    Oliver Juhas
    Keymaster

    Hi Oliver Juhas,

    1. Left and right padding on a column via the BB settings and, again, the theme overrides this setting

    Yes, like I’ve mentioned, the theme overrides this horizontal padding. But you can either force it via custom CSS for all columns if really needed or set this per column basis.

    2. I am trying to equalize 2 columns and align their content in the middle (this is a standard BB feature) and, again, the theme will not let me do it.

    The theme equalizes the columns out of the box by default. As for the vertical column alignment, thank you, you’ve spotted a bug. I will fix it ASAP. The theme also adds this feature to the row setting where it works perfectly fine actually.


    Maybe in your case some custom CSS tweaks would work best actually. Can you please describe in more details what spacing you need to apply on various Beaver Builder elements (rows, columns, modules)? The theme was designed to apply its own spacing on those modules for the best and easiest design process.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 10 posts - 1 through 10 (of 12 total)
  • You must be logged in to reply to this topic.