Blog post – featured image and unwanted element

Home Forums Modern Blog post – featured image and unwanted element

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #19314

    VanBard
    Participant

    Blog post – featured image and unwanted element

    Resolved

    Hello,

    I’ve found a similar thread on the forum, but the solutions provided didn’t work.

    The featured images appear as too small thumbnails on the blog page, instead of covering the same space it takes on the demo.

    I tried to upload with the sizes recommended in Settings > Media, but it didn’t solve the problem. I also installed Imsanity like it is advised in another thread.

    Furthermore, the featured image then appears at the very beginning of the post and I don’t know how to avoid it : it doesn’t show up in the editor.

    A more minor but annoying issue is the presence of two lines under the title. I don’t know why, but it didn’t happen on the first post I’ve made, and I also don’t know how to remove it.

    I join you screenshots and the URL so you can check easily.

    I really like the theme so far anyway, it’s very elegant and user-friendly, but I’m quite a beginner ;-)

    • This topic was modified 1 month, 3 weeks ago by  VanBard.
    #19322

    Oliver Juhas
    Keymaster

    Hi VanBard,

    Thank you, I’m glad you like the theme :)

    Please note that once you set a different media sizes in WordPress admin, you need to regenerate the sizes for all the images you already uploaded to your website. This can be done using a plugin such as “Force Regenerate Thumbnails” as stated in theme documentation.

    Imsanity plugin only helps you keep the max size of the uploaded images under control, it will not help you with your issue.

    On single post pages the featured image is displayed at the beginning of the post before the post title. This is automated and by theme design. This can be seen in theme demo website too. However, you can disable this featured image display in Appearance → Customize → Content Options once you install and activate Jetpack plugin.

    The 2 lines are displayed on post meta container. It seems you have hidden all post meta info in Content Options (please note that this is not really recommended, posts should at least display their publish date) but the container stays there. To hide the container itself, please use this custom CSS:

    .entry-meta {
    	clip: rect(1px, 1px, 1px, 1px);
    	height: 1px;
    	position: absolute;
    	overflow: hidden;
    	width: 1px;
    }

    Best regards,

    Oliver Juhas
    WebMan Design

    #19323

    Oliver Juhas
    Keymaster

    Also, if you are new to WordPress, please read/watch tutorials linked in “First Steps With WordPress” section of the theme documentation.

    A more minor but annoying issue is the presence of two lines under the title. I don’t know why, but it didn’t happen on the first post I’ve made, and I also don’t know how to remove it.

    To explain your first post I have to say there is a setup issue on your website. You have created a page and a post with exact same content, same title and same permalink. And as the pages take prime in WordPress (or you have created that one first), once you click the post link, it actually displays the page, not the post. And pages does not have post meta, that’s why the 2 lines are not displayed there. Please, do not create multiple instances of a content on your website. You will prevent issues like I’ve just described, but also prevent search engines (such as Google) penalization for duplicate content.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19324

    VanBard
    Participant

    Hello Oliver,

    Thank you very much for your help!

    I still cannot set the tumbnail right though, on the blog page. I didn’t change anything in the WordPress admin about the recommended size, I simply tried to upload images respecting the advised sizes there (1024×1024 for instance), so I suppose that the Force Regenerate Thumbnail wouldn’t help (?)

    The problems of the thumbnail image at the beginning of a post and of the container are solved.

    I also understand the issue concerning the page being identical to a post now, thank you. I am only starting the blog and testing, hence the duplicate ;-)

    Best regards.

    #19325

    Oliver Juhas
    Keymaster

    Hi VanBard,

    In that case you should actually make changes to the media size in WordPress admin first. Please match media settings to theme recommended sizes (notice the “Recommended image sizes” info) like so:

    Then use Force Regenerate Thumbnails plugin as mentioned in my previous reply to regenerate already uploaded images to their new sizes too.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19329

    VanBard
    Participant

    It worked!

    Thank you very much, Oliver.

    • This reply was modified 1 month, 3 weeks ago by  VanBard.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.