Cross-sell products not showing

Home Forums Monument Valley Cross-sell products not showing

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #17705

    Keith
    Participant

    Cross-sell products not showing

    Resolved

    I have several products that I have linked to another item as cross-sell however I do not see the cross-sell item displaying anywhere. I have looked at the product page and in the shopping cart. Am I missing a step in the setup?

    I have also noticed that the styles for of the Cart page break when I have the WooCommerce Checkout Add-Ons plugin enabled and use the file upload field.

    #17708

    Oliver Juhas
    Keymaster

    Hi Keith,

    The cross sell products can not be previewed in single product page. They are only visible on cart page when you add the product with cross sells set. You can see this in theme demo website when adding “Rolleck’s Watches” product to the cart.

    Or maybe you are looking for upsell products?

    As for WooCommerce Checkout Add-ons plugin, please note that the theme applies special styles for checkout page to make it more conversion optimized. This is very similar to Storefront theme, for example.
    This, however, differs from default WooCommerce checkout page styles and the plugin you are using works best with that default layout.
    To fix the issue, you can ask the plugin support for a solution (maybe you can move the field somewhere within theme-styled WooCommerce containers – the theme does not modify the HTML of those), or you can apply custom styles as suggested in one of previous support tickets, or you can revert back to default WooCommerce checkout page layout using this custom CSS:

    .woocommerce-checkout:not(.woocommerce-order-pay):not(.woocommerce-order-received) .col2-set,
    .woocommerce-checkout:not(.woocommerce-order-pay):not(.woocommerce-order-received) .col2-set + h3,
    .woocommerce-checkout-review-order {
    	float: none;
    	width: auto;
    }
    
    @media only screen and (min-width: 55em) {
    
    	.woocommerce-checkout:not(.woocommerce-order-pay):not(.woocommerce-order-received) .col2-set {
    		overflow: hidden;
    	}
    
    	.woocommerce-checkout:not(.woocommerce-order-pay):not(.woocommerce-order-received) .col2-set .col-1 {
    		float: left;
    		width: 48%;
    	}
    
    	.woocommerce-checkout:not(.woocommerce-order-pay):not(.woocommerce-order-received) .col2-set .col-2 {
    		float: right;
    		width: 48%;
    	}
    
    }

    Best regards,

    Oliver Juhas
    WebMan Design

    #17713

    Keith
    Participant

    For example, I have a framed product and an easel. They are both entered showing as cross-sells of each other. When I go to the cart, I do not see the “You may be interested in” block. Do I need to add that to the cart template somehow? I am using

    WordPress 4.9.4
    Monument Valley 1.4.6
    WooCommerce 3.3.1

    #17714

    Oliver Juhas
    Keymaster

    Hi Keith,

    First, please update the theme to 1.4.7 version.

    Linked products are WooCommerce native functionality and the theme does not remove any of those. After you set them up correctly, they should work. Here is how the linked products are set up for theme demo website:

    You can simply install theme demo content to see how the thing are set up in WooCommerce, or read WooCommerce documentation. The theme does not modify the linked products display in any significant way, it basically only styles their display.

    Maybe some of your plugins are colliding here? Try to disable all the plugins excerpt WooCommerce (and WebMan Amplifier, and Beaver Builder) to see if that helps.

    If none of these works for you, you can log a ticket with WooCommerce and maybe provide admin access to your website so I can check personally too.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.