Error when clicking to edit anything with PRO version of Beaver Builder

Home Forums Forstron Error when clicking to edit anything with PRO version of Beaver Builder

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #18360

    PabloB
    Participant

    Error when clicking to edit anything with PRO version of Beaver Builder

    Resolved

    Hello, i purchased the template license and also the Beaver Builder Standard License.

    First i configured everything in localhost with the Lite version provided by you, ok.

    Once i had everything done i realased that i can not export my design to live because the Lite version does not support that.. ok.. so i bought the Beaver Builder License for 1 year.

    Now, once installed the pro version of Beaver Builder i can not clic ober anything inside Beaver Constructor.

    If i deactivate the pro version it works with Lite but i need to export the design from local to live. I tried to copy all the data base and server files. Didn’t work. Everything is copied except the styles designed in local with Lite version.

    How can i make it work with pro version?

    Hope your can answer soon.

    I have the purchase code if you need it.

    Regards

    #18361

    Oliver Juhas
    Keymaster

    Hi PabloB,

    Thank you for your purchase!

    The issue you are experiencing is resolved in the most recent theme version of 1.6.3. Please update your theme to resolve the issue.

    Once i had everything done i realased that i can not export my design to live because the Lite version does not support that..

    I think this should work perfectly fine even with lite version of Beaver Builder. You see, you were able to import the theme demo content to your website, and the demo content was built using the free Beaver Builder Lite Version.

    There are some dedicated plugins that are actually able to migrate your localhost development site to a live site. That’s how many of my theme users actually built their website with success. You might run into issues during migration process you can read about in knowledge base article.

    You can also read other support tickets regarding website migration.

    Best regards,

    Oliver Juhas
    WebMan Design

    #18376

    PabloB
    Participant

    Hello!

    Thank you for your reply.

    I had the latest version of Forstron (1.6.3) directly downloaded fomr envato market after purchase. So, in my case, this version doesn’t fix the issue with the Pro Version of Beaver Builder.

    I’wll try to explain a bit better.

    There are two different problems.

    1: On migration from local to live, the design doesn’t load the styles, backgrounds, etc. By the other hand the content is on there.

    2: Once purchased Beaver Builder Standard License, installed and activated, can not clic into anything, even can not export, import templates or design

    PROBLEM 1 DETAILED

    About the migration issue, thank you for your links and advices. However, i’m sure all the migration was well performed, i always prefer to perform the migration withouth plugins.

    The migration from localhost to live was properly done. Every single tag, category, page, content, images, menus, custom configuration, etc was migrated succesfully. The problem is that the design done in every page get lost. All the content is there but the structure brokes.

    When i speak about design i refer to:

    – On localhost import Forstron demo content.
    – Modified everything with provided Beaver Builder Lite to match my project needs.
    – Final design content at the end is not equal to the original demo, of course. Demo was used to check the functionality of BB and design custom sections, backgrounds, widths, etc. Eveything always with BB Lite.

    If i try to edit with Beaver Builder Lite on live server after migration it doesn’t load colors, styles, width, etc. Only mantain the order of every section.

    The problem is that one. Everything works and is on there, but the desing made in localhost doesn’t load. Maybe due to caché or tokens??

    Steps done trying to fix what is explained lines above:

    – Clean Beaver Builder cache before export from localhost. Didn’t work.

    – Install a clean WordPress latest version in live, install clean version of theme. Export only XML data from WordPress importer tool from localhost. Imported to live version. Didn’t work.

    – Upgrading Beaver Builder to Standard License to export the templates and import that inside live version. This broke the clic option, can not save template, can not clic on any field to modify any module like “WM Content Module” etc.

    PROBLEM 2 DETAILED

    Once purchased Beaver Builder Standard License i have the option to “Save” the template, rows, modules, etc.

    The issue is that can not clic in anything (with BB Standard installed and activated). It looks like something is not compatible or maybe exists a conflict between “Forstron WM amplifier” and Beaver Builder Standard License.

    Some clues:

    If BB Standard is deactivated and only keep the Theme original Beaver Builder Lite versión everything works, but can not export the design to live.

    – Deactivating the BB Lite version didn’t fix the problem.

    – Keeping BB Lite and BB Standard together didn’t fix the problem.

    I hope you can help in some way or bring some clues about how can be this fixed.

    Thank you ina dvance and best regards,

    #18382

    Oliver Juhas
    Keymaster

    Hi PabloB,

    I understand your issues.

    Please understand that it’s almost impossible doing migration without plugins or some tool that will migrate the serialized database records properly. Especially Beaver Builder stores layouts in serialized records, so, when you change the URL of your website simply by find and replace, this will break serialization and thus your layouts.

    With Beaver Builder you can also try flushing your layouts cache and that should theoretically update the URLs on your live website too (please check the plugins documentation for more info on this). You don’t really need to flush the plugin’s cache before migration.

    Also, please contact Beaver Builder support on how to properly migrate the plugin’s layouts from localhost to live website. Please understand that the plugin is not related to the theme and this is not a theme issue. Beaver Builder support will provide you with more details on how to do this properly.

    Using WordPress export/import feature will not work when migrating from localhost to a live website. Your localhost is not accessible from internet, so your live website can not download the assets.

    As for Beaver Builder editor problem, please try to disable all plugins except Beaver Builder and WebMan Amplifier.
    You see, there seems to be some JavaScript error, possibly coming from a plugin that breaks Beaver Builder‘s functionality. You can actually check this on your own using your web browser’s console.
    If the issue still persists, please provide me with admin access to your website so I can check whether the issue is related to the theme and provide the solution.

    I can assure you (most recent) WebMan Amplifier works with all versions of Beaver Builder plugin. I have them installed on my localhost test environment without any issues.

    Best regards,

    Oliver Juhas
    WebMan Design

    #18383

    PabloB
    Participant

    Please understand that it’s almost impossible doing migration without plugins or some tool that will migrate the serialized database records properly. Especially Beaver Builder stores layouts in serialized records, so, when you change the URL of your website simply by find and replace, this will break serialization and thus your layouts.

    Perfect, thank you for the information. That is all i need. If i solve the issue with a proper migration with serialize in mind i’ll share the result here.

    Regards!

    #18384

    Oliver Juhas
    Keymaster

    Hi PabloB,

    Please, contact Beaver Builder support as they will surely be able to provide you with some help and tips on how to properly migrate the plugin data.

    The theme does not have the similar issues as stated in “Website migration” knowledge base article.

    Best regards,

    Oliver Juhas
    WebMan Design

    #18385

    PabloB
    Participant

    Hello,

    Already fixed. The pro version of Beaver Builder is not necessary to migrate from local to live server.

    If someone has the same issue and want to fix migration issues with BB builder, the following steps do the trick, for me at least. Although i prefer to avoid plugins currently this is the best-fast-solution.

    Step 1: Export localhost database.

    Change only the site URL to access admin panel.

    Usually inside wp_options

    (1, 'siteurl', 'http://yourdomain.com', 'yes'),
    (2, 'home', 'http://yourdomain.com', 'yes'),

    Step 2: Replace data base URL properly

    For a proper data migration install better search replace plugin.

    Perform the replace, table by table with the plugin. It will keep the serialize database order.

    Step 3: Check in front everything works.

    Some images may need to be edited. You can go to Beaber Builder, change the image for another one, save, go again inside BB, restore the original image and save.

    Thank you and regards,

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.