hover color incorrect on css button hover

Home Forums Icelander hover color incorrect on css button hover

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #21660

    jamnbiscuits
    Participant

    hover color incorrect on css button hover

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    I have icelander theme installed with beaverbuilder.
    It shows red on hover but should be orange (#ff5800) as set in themes>theme options>accents.

    I should note that I have auto optimize plugin that caches css etc.installed and suspect it causes issues.

    For instance I can disable CSS in autooptimize and my hover works but I lose styling on my header/main menu fonts. I also lose my fontawesome icons.

    thanks

    #21663

    Oliver Juhas
    Keymaster

    Hi jamnbiscuits,

    I can see the Autoptimize combines the stylesheets into 3 cached files. And indeed, the accent color is correctly set to the value you’ve set in theme options. However, Autoptimize doesn’t seem to pick up the correct order of the stylesheets. It put your customized colors into a cached stylesheet that is loaded before the cached stylesheet that contains the original theme colors. That’s why theme colors overrides your customizations.

    I’ve tried to install Autoptimize, but I can’t replicate your issue – everything works perfectly fine for me with the default plugin settings. There is even some “Also aggregate inline CSS?” option in Autoptimize plugin settings, but it doesn’t seem to do anything for me…

    I suggest contacting Autoptimize support to solve this issue and ask them about styles order. Maybe you can even tweak some plugin option to fix the issue?

    Anyway, disabling Autoptimize should not cause other issues, like loosing styling on your header/main menu fonts. I don’t know what styles have you applied here, but it might be just a matter of CSS specificity. It has nothing to do with Autoptimize.

    The same should apply for Font Awesome icons. BTW, did you know you can set a custom set of icons in the theme?

    Tip: Please note that combining and minification of any CSS and JavaScript should be done carefully. It is a complex process that can cause many issues.

    Tip: I personally use WP Rocket plugin for website optimization and never had an issue.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.