No Social Media Icons & Changed CSS after Update

Home Forums Icelander No Social Media Icons & Changed CSS after Update

Viewing 10 posts - 1 through 10 (of 17 total)
  • Author
    Posts
  • #20495

    compra
    Participant

    No Social Media Icons & Changed CSS after Update

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    Hi,

    first of all I’m using a child theme to make my css modifications.
    But after I updated my parent-theme I got totally different font-sizes, colors and even the website logo was smaller than before.
    I figured out, that if I’m replacing the “frontend”, “setup” and “customize” folder from the “includes” folder of the actual parent-theme with the old ones, I’m getting my old styles back again.
    How can this happen?

    The second thing is, that for no reason the social media icons vanished. I have absolutley no idea why, because I didn’t do anything and they worked before.
    I created a menu with two individual links (facebook & youtube) and than I linked that menu to the social media area.
    I already created the menu etc. from scrath and linked it back again, but it didn’t help.

    Any idea, what I can do? I have totally no clue.

    I add two screenshots of the websites. The one with the correct styles is the live-system, but there are missing the social media icons.
    The other one is my staging system with the updated theme, which has the false styles but showing the social media icons.
    On the live-website there is icelander 1.3.4 active
    On the staging there is 1.4.1.

    thanks :)

    #20497

    Oliver Juhas
    Keymaster

    Hi compra,

    Please note that version 1.4.0 introduced styles via CSS variables. But these should not really affect custom styles in your child theme, but of course, this might depend on your child theme actual styles. Please adapt your child theme custom styles to new styles paradigm. Or you can provide your website URL so I can have a look what styles are being overridden on your website and provide you with info why. (Or use your web browser code inspector to determine the override yourself.)

    You can see changelog.md file inside the theme folder for more info about what has changed in the theme.

    Please do not replace any folders/code with old one!
    The font size, colors and website logo height can all be set in theme options in Appearance → Customize → Theme Options (and Appearance → Customize → Site Identity respectively), there is no need to override these in your child theme.

    Social media icons should not vanish, actually. But just to make sure, please navigate to Appearance → Customize, change something, change it back and save/publish your changes so the theme options get refreshed. You can also navigate to Appearance → Menu, select your social links menu and re-save it so WordPress flushes any cache related to this menu.

    Also, please note that all of these tips are related to parent theme. If you override any of these functionalities via your child theme, you might need to update your child theme code. I suggest switching to Icelander parent theme to make the changes and then to switch back to your child theme so you know what issues are actually coming from the child theme.

    If the above solutions don’t work, please provide your website admin login so I can check personally.

    Best regards,

    Oliver Juhas
    WebMan Design

    #20498

    Oliver Juhas
    Keymaster

    Also, looking at your screenshot, I think a person from your team has already asked some questions. Please check the previous support ticket.

    Best regards,

    Oliver Juhas
    WebMan Design

    #20499

    Oliver Juhas
    Keymaster

    And, when I look at your website (visiting the URL provided in the other support ticket) I don’t really see any custom styles from your child theme that should actually override the theme options after you upgrade the theme.

    Please make sure you flush your browser cache after theme upgrade so the new styles could be applied without any issue. Also, if you are using any server caching solution, please flush the cache.

    As for social icons, I can see the menu is actually not picking up the correct new HTML, that’s why the icons are not displayed. Re-saving your social menu in your WordPress admin should fix the issue (under condition you are not overriding it in your child theme somehow – please check your child theme PHP code).

    Best regards,

    Oliver Juhas
    WebMan Design

    #20500

    compra
    Participant

    This is a private reply!

    This reply has been marked as private.
    #20502

    Oliver Juhas
    Keymaster

    Hi compra,

    Thank you for your access details, but please note that you should create a new temporary admin for me – please read terms of service.

    Also, please note that I can not access your staging website and if I understand correctly, you haven’t updated the live website to new theme version. Please grant me access to your staging website or upgrade the theme on your live website so I can check there. (You can put your website into maintenance mode meanwhile if possible, for example.)

    Thank you.

    Best regards,

    Oliver Juhas
    WebMan Design

    #20505

    compra
    Participant

    Excuse me, we had to set the staging URL public.
    You should now be able to access to the staging system.

    But we can’t set the Live-System to a maintenance mode, that’s why we got a staging area.
    But except for the missing social media icons, its an 1:1 reflection of the Live-System.

    #20506

    Oliver Juhas
    Keymaster

    Hi compra,

    Thank you, I can confirm I can access staging website now. Please, provide me with a new temporary admin access to the website. I have deleted the access info you have provided before as it was access credentials for an existing account (probably yours?). Please read terms of service (see the links below) for how to create temporary admin accounts.

    Best regards,

    Oliver Juhas
    WebMan Design

    #20507

    compra
    Participant

    This is a private reply!

    This reply has been marked as private.
    #20508

    Oliver Juhas
    Keymaster

    I can immediately see where is the problem on your staging website, so you don’t actually need to create any account for me.

    The icons are working correctly on your staging website as you can see, so I consider this resolved with theme update.

    And the styles are being overridden via your child theme. There is really no need for you to override the assets/css/custom-styles.css in your child theme, for example. Please remove all the file overrides from your child theme to resolve the issues. The Icelander theme is full of action and filter hooks so you should be able to override any functionality via your child theme functions.php file – there is no need to override parent theme files.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 10 posts - 1 through 10 (of 17 total)

You must be logged in to reply to this topic.