Home Forums Polyclinic polyclinic -accessibility

Viewing 6 posts - 11 through 16 (of 16 total)
  • Author
    Posts
  • #19934

    Oliver Juhas
    Keymaster

    Also, you can test other sites too. For example when I check https://wordpress.org/ in Firefox, the “Reader view” is not available. However, when I check https://wordpress.org/news/, the “Reader view” is available, which brings me to conclusion it has something to do with blog articles.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19935

    Oliver Juhas
    Keymaster

    But honestly, looking at https://wordpress.org/news/ source code, I really have no idea how Firefox “Reader view” works. The source code on https://wordpress.org/news/ is actually not really semantic, unlike it Polyclinic theme, so it should not work really. I don’t understand how Firefox “Reader view” sees the information as blog articles…

    Best regards,

    Oliver Juhas
    WebMan Design

    #19936

    Oliver Juhas
    Keymaster

    According to https://www.howtogeek.com/268116/is-there-a-way-to-force-enable-reader-view-in-mozilla-firefox/ (and following links) it seems the “Reader view” needs “properly formed HTML code”.

    So, again, I suggest you test your website with accessibility tools and fix your website content to meat requirements. The theme demo content is built with accessibility in mind. But this is a content, not a theme code.

    I would start with checking your headings structure first.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19937

    Oliver Juhas
    Keymaster

    But now that I check theme demo website, the Firefox “Reader view” doesn’t work for all pages… So, I really have no idea how it works. All of theme demo pages are well structured and pass accessibility test, so I really can not figure out why “Reader view” is not enabled for them. Sorry.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19938

    Oliver Juhas
    Keymaster

    Another thought I have you can try is to use some microformats plugin to improve your page content SEO and structure. Maybe that will cause the “Reader view” to activate.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19939

    Oliver Juhas
    Keymaster

    OK, one last thought that seems to be working for me. I’ve tested the behavior of “Reader view” in Firefox and here is what I’ve found:

    • Your page needs to contain some text in paragraph (the <p> HTML tag).
    • There seems to be some minimal length of text in paragraphs required for “Reader view” to be enabled. But this length is inconsistent (let’s say 600+ characters), depends on number of paragraphs and length of text in each paragraph. Please test yourself to see.

    Hope this helps.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 6 posts - 11 through 16 (of 16 total)

You must be logged in to reply to this topic.