Problem with install of demo content (log file available)

Home Forums Modern Problem with install of demo content (log file available)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18983

    rusher7
    Participant

    Problem with install of demo content (log file available)

    Resolved

    Hi,

    I encountered a problem with your theme, so I deleted my blog and reinstalled the theme along with its required plugins and many recommended (by you) plugins, along with some of my own. In the midst of plugin installing, I upgraded my server’s PHP to version 7.2, if that’s at all relevant. I purposely did all this installing, and making an UpDraft backup, before importing demo content so I could see if anything I want enabled caused the problem previously. Also of note is that when I was importing, I had zero content; trashing the posts, comments and pages of default WP install. I am using WP 4.9.7, I believe.

    I will provide log file on request, in private, since it contains sensitive information. Here are the errors.

    Errors:

    [ERROR] Failed to import "SAMPLE/_rob-potter-398564" (Media)
    [ERROR] Failed to import "SAMPLE/_rob-potter-364323" (Media)
    [ERROR] Failed to import "SAMPLE/_marcus-cramer-455992" (Media)
    [ERROR] Failed to import "SAMPLE/_nikolai-voelcker-455917" (Media)
    [ERROR] Failed to import "SAMPLE/_armando-castillejos-140540" (Media)
    [ERROR] Failed to import "SAMPLE/_hollie-harmsworth-392580" (Media)
    [ERROR] Failed to import "SAMPLE/_nick-adams-457460" (Media)
    [ERROR] Failed to import "SAMPLE/_nik-shuliahin-359344" (Media)
    [ERROR] Failed to import "SAMPLE/_will-swann-459480" (Media)
    [ERROR] Failed to import "SAMPLE/_alessio-lin-427614" (Media)
    [ERROR] Failed to import "SAMPLE/_alessio-lin-455449" (Media)
    [ERROR] Failed to import "SAMPLE/_liam-simpson-421994" (Media)
    [ERROR] Failed to import "SAMPLE/_pietro-de-grandi-455251" (Media)
    [ERROR] Failed to import "SAMPLE/_paul-johnston-458400" (Media)
    • This topic was modified 1 week, 2 days ago by  rusher7.
    • This topic was modified 1 week, 2 days ago by  Oliver Juhas. Reason: Removing list of installed plugins - irrelevant for this issue
    #18985

    Oliver Juhas
    Keymaster

    Hi rusher7,

    Please note that the demo content seems to be imported correctly, except media files were not. This can be for many reasons, one of which could be the broken internet connection to my servers. As stated in theme documentation, the demo media files are only for demo purpose and should be replaced anyway, so you can go ahead and use your website even now.

    You can find more information about demo content import and issues that may occur in theme documentation at https://webmandesign.github.io/docs/modern/#demo-content

    Also, you do not need a huge list of plugins installed to import demo content. Really, only 3 plugins are required to import the theme demo content (+ One Click Demo Import plugin if you want to import the demo easily).

    I’ve went ahead and tested the one click demo import again and everything works perfectly fine for me. Here is the result of my test:

    Tip: If you decide to run the demo import process again, you don’t have to reinstall your WordPress. Instead try using a reset plugin such as https://wordpress.org/plugins/reset-wp/ (though, please note that the plugin does not delete any previously imported files from uploads folder, so I suggest deleting them manually via FTP under PATH_TO_YOUR_WP/wp-content/uploads).

    Tip: Maybe checking your PHP settings will also help with demo import process?

    Best regards,

    Oliver Juhas
    WebMan Design

    • This reply was modified 1 week, 2 days ago by  Oliver Juhas. Reason: Fixing typos
    #18986

    Oliver Juhas
    Keymaster

    Tip: Try not to enable all the plugins you are using and enable only the ones required for demo import. Maybe that could also help.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19006

    rusher7
    Participant

    Hi, thank you for the prompt reply. Some things of note:
    1) It wasn’t this problem that made me reset the blog, but the arrows in slider of the theme becoming uncentered. This image/menu problem happened with the reinstall after nuking the WP site because of that slider issue.
    2) The front-end header menu w/ dropdowns did not seem to import correctly or the same as last time, which made me worried about more than just the pictures. Is it fine?
    3) I upgraded to PHP 7.2 after installing your theme and after many plugin installs. Any other upgrades would be afterward, too. If the menu isn’t fine, should I nuke and reinstall with proper MySQL and PHP 7.2 from beginning of process?
    4) I had JetPack installed but testimonials and portfolio disabled before importing.

    Disabling all my plugins but required ones and importing the demo again in a reset is just as much work as nuking WP and reinstalling again. If the menu being messed up isn’t indicative of a deeper problem with the import, then I will keep the theme as-is. If it is indicative, then I will reset with your suggestions.

    Also, I don’t know if it is related to the import issue, but on the page with comments example on my site, the text for the checkboxes under the Jetpack comment module are an unreadable white against white background.

    • This reply was modified 1 week, 2 days ago by  rusher7.
    #19013

    Oliver Juhas
    Keymaster

    Hi rusher7,

    I’m sorry, it’s really hard to tell what could go wrong with import process on your website. I bet it’s related to server setup. Please read the linked articles from the theme documentation – there are descriptions of import issues that might happen.

    The theme demo content is a standard WordPress export file (Tools → Export) and it should work. (Like I’ve mentioned, I’ve tested it now and works without any issue for me.) You can try also the default WordPress manual import procedure (see theme docs), but I predict you will experience the same/similar issues.

    Do you use a low cost hosting? If I run your website through whoishostingthis.com, it returns “CloudFlare”, which is a CDN service. First I suggest disabling CloudFlare or any other CDN and caching while you are building your website.
    I really strongly suggest checking your PHP settings, as mentioned in my previous reply (not the PHP version, but actual settings).
    Then I strongly suggest installing the theme on your own computer and test it there. The theme should work perfectly fine. If it does, you know the issue is with your live website server/hosting setup.

    When you don’t enable Jetpack custom content types, they will simply not be imported. (However, I can see the Portfolio and Testimonials correctly imported on your website…)

    Jetpack comments module replaces default WordPress comments and applies its own custom styles. You can either change its color scheme to “Light” (as your website content area is lightly colored too), or disable it, or apply your custom CSS to fix this:

    .highlander-dark #respond label {
    	color: inherit;
    }

    (Please use your browser code inspector to determine what CSS code you need to use to fix any plugin styling issues or modify the theme styles.)

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.