Problems with site nav and Beaver Builder

Home Forums Monument Valley Problems with site nav and Beaver Builder

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20081

    MajesticMess
    Participant

    Problems with site nav and Beaver Builder

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    I’m using Monument Valley, which I see is a Beaver Builder compatible theme. After updating to WordPress 5.0.1, any page made with Beaver Builder gets cut off by the top nav if the page is wider than ~1257px with the page border showing. If the page is too narrow for the border to show, the page works fine, which is why I think it’s a theme issue. Pages built with Gutenberg work fine. This happened before and after updating the Monument Valley theme from second latest to latest build.

    #20084

    Oliver Juhas
    Keymaster

    Hi MajesticMess,

    Please note this is not an issue with theme update. It seems you are hiding the theme intro section using Beaver Builder global settings. This does not work correctly when using sticky header on your website.

    To resolve, please enable the page header in Beaver Builder global settings and use theme’s “No intro” page template instead, which is better solution for such cases.

    If you still want to continue using the Beaver Builder global setting solution, please apply this custom CSS to fix the issue:

    @media only screen and (min-height: 28em) and (min-width: 80em) {
    	.has-sticky-header.has-intro.fl-builder:not(.no-js) .site-header-placeholder {
    		display: block;
    	}
    }

    Best regards,

    Oliver Juhas
    WebMan Design

    #20087

    MajesticMess
    Participant

    Works perfectly now. Never even noticed that setting. Thanks for the help.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.