Product image cutting off

Home Forums Icelander Product image cutting off

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20142

    cryptokin
    Participant

    Product image cutting off

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    The initial product image is cutting off at the bottom. About 1/3 of the bottom portion of the image is always cut off when visiting the product page(s). When no gallery is present, the full image shows up normally. When gallery is present, image gets cut off. When viewing other images in gallery, then going back to the first one, it’ll show the correct size. It’s just the initial image is problematic.

    #20143

    Oliver Juhas
    Keymaster

    Hi cryptokin,

    I don’t think the issue is related to the theme, actually. It seems like the Jetpack’s Lazy Images is enabled on your website and it interferes with WooCommerce’s product image gallery.

    I suggest logging a support ticket with Jetpack plugin and describe the issue. They should fix it as WooCommerce is provided by the same company, Automattic ;)
    Alternatively simply disable the Jetpack’s Lazy Images to resolve the issue.

    Best regards,

    Oliver Juhas
    WebMan Design

    #20144

    Oliver Juhas
    Keymaster

    Actually, according to https://developer.jetpack.com/hooks/lazyload_is_enabled/ you can also try to disable the Lazy Images for products. Try to use this code in your child theme‘s functions.php file:

    function child_theme_lazy_images_exclude( $enabled ) {
    	if ( function_exists( 'is_product' ) && is_product() ) {
    		return false;
    	}
    
    	return $enabled;
    }
    add_filter( 'lazyload_is_enabled', 'child_theme_lazy_images_exclude', 15 );

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.