question about all caps in navigation menu and problem with header-image (mobile

Home Forums Modern question about all caps in navigation menu and problem with header-image (mobile

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18289

    timri
    Participant

    question about all caps in navigation menu and problem with header-image (mobile

    Resolved

    Hi Oliver Juhas,

    I am building a new page (not finished) and come to a question and a problem, for which I did not find any answers in the forum. So I hoped you maybe have an idea or two.

    a)
    The sidbar navigation menu (on the right on the homepage) and the tag cloud only display the links in all caps. But I would like to have them in small letters.
    Is there a way to change that manually or other ways? Or another way to include a sidbar navigation menu then with design – customizer – widgets – sidebar – add navigation menu widget?

    b)
    I have a problem with a difference between PC and mobile theme (see the attachment). The left seems to be correct (Pc version), but on the right one (mobile, tablet version) the header image starts in the middle and not on the left. Looks kind of strange.
    I use a standard header image for most pages, but for some pages I use “Intro options – Custom intro image” for a different header picture.
    Is there a way to fix it or another way to use different header images for different pages?

    And last but not least, thanks again for the great wordpress theme!
    Greetings,
    Tim

    #18293

    Oliver Juhas
    Keymaster

    Hi Tim,

    Thank you, I’m glad you like the theme :)

    1. This is how theme styles the “Navigation Menu” and “Tag Cloud” widget. If you don’t like the uppercase letters in those, you can switch it off using custom CSS:
      .widget .tagcloud a,
      .sidebar .wm-subnav li a,
      .sidebar .widget_nav_menu li a {
      	text-transform: none;
      }

      However, please note that using the navigation in sidebar you are basically already duplicating the navigation from your header. In my opinion, there is no point to have 2 exactly same navigations, one in the header (which is default – see theme demo) and one in sidebar (added by your widget).

    2. Please note that the image starts in the middle due to your custom CSS (the body:not(.home) .intro-media img one). You should modify your CSS code to work on mobiles too. Perhaps this could help:
      body:not(.home) .intro-media img {
      	width: auto;
      	margin: 0;
      	-webkit-filter: none;
      	filter: none;
      }
      
      @media only screen and (min-width: 55em) {
      	body:not(.home) .intro-media img {
      		width: 100%;
      		-webkit-transform: none;
      		-ms-transform: none;
      		transform: none;
      	}
      }

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.