Server status 500 with Awesome Support Plugin

Home Forums Monument Valley Server status 500 with Awesome Support Plugin

Viewing 10 posts - 1 through 10 (of 13 total)
  • Author
    Posts
  • #21818

    wilderkaiser
    Participant

    Server status 500 with Awesome Support Plugin

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    Hello, opening a ticket is NOT displaying the ticket editor page. Only Headline is displayed. In Chrome Debug console i have this error:

    "Failed to load resource: the server responded with a status of 500 ()"  
    in 
    "../wp-admin/post.php?post=142042&action=edit&tgmpa-dismiss=dismiss_admin_notices&_wpnonce=..."

    Tested this also with Storefront Theme-(edited)-issue is gone- plugin working

    Debug Mode is displaying following errors: see attachment …

    How to proceed? I can grant backend access if you send your related eMail Adress …

    Thanks in advanced

    [ ADMIN EDIT: REMOVING PURCHASE INFO ]

    • This topic was modified 3 weeks, 2 days ago by  Oliver Juhas. Reason: Formatting code
    • This topic was modified 3 weeks, 2 days ago by  wilderkaiser.
    • This topic was modified 3 weeks, 2 days ago by  Oliver Juhas. Reason: Formatting code
    • This topic was modified 3 weeks, 2 days ago by  Oliver Juhas. Reason: Removing sensitive info
    • This topic was modified 3 weeks, 2 days ago by  wilderkaiser.
    #21824

    Oliver Juhas
    Keymaster

    Hi wilderkaiser,

    Please note that this issue is not related to the theme. You actually mentioned you’ve tested this with a different theme and the issue persist.

    Please understand that I can only provide support for my products. If you experience issues using a plugin, please contact the plugin support.

    You can try tips in a knowledge base article of this support center, but you are really better checking with plugin developer.

    Best regards,

    Oliver Juhas
    WebMan Design

    #21828

    wilderkaiser
    Participant

    Sorry, think there is a misunderstanding. Of course the issue isnt present with other themes (storefront for example) so this is related to your theme :-(

    Best regards

    #21829

    Oliver Juhas
    Keymaster

    Hi,

    I see. I thought the result was the same with Storefront theme.

    Have you checked the tips from the knowledge base article? Have updating PHP and checking/updating PHP settings helped resolve the issue?

    Best regards,

    Oliver Juhas
    WebMan Design

    #21831

    wilderkaiser
    Participant

    yes … all tests pass …

    PHP info: [ ADMIN EDIT: URL REMOVED ]

    • This reply was modified 3 weeks, 2 days ago by  Oliver Juhas. Reason: Making the post public as there is no sensitive information shared
    #21833

    Oliver Juhas
    Keymaster

    Hi wilderkaiser,

    I’m sorry, but I have no access to that URL ;)

    In that case please provide admin access to your website. Also, please provide exact steps how I can reproduce the issue so I can test. Thank you.

    Best regards,

    Oliver Juhas
    WebMan Design

    #21834

    wilderkaiser
    Participant

    This is a private reply!

    This reply has been marked as private.
    #21835

    Oliver Juhas
    Keymaster

    Hi wilderkaiser,

    Thank you for the access details. Could you please set your website admin language to English. It does not work using standard WordPress options. Thank you.

    Best regards,

    Oliver Juhas
    WebMan Design

    #21836

    wilderkaiser
    Participant

    HI again,

    sure – already set “backup language” also to EN ;-)

    Regards Joerg

    • This reply was modified 3 weeks, 2 days ago by  Oliver Juhas. Reason: Making the post public as there is no sensitive information shared
    #21838

    Oliver Juhas
    Keymaster

    Hi Joerg,

    Thank you. You can revert back to German language (though I suggest using default WordPress option for that by setting a language in Settings → General – that way a user can override this language to his/her needs).

    This issue was very tricky… But I’ve managed to trace it ;)

    The issue is indeed related to Awesome Support plugin. They apply WordPress native the_title filter hook incorrectly in their code, with only 1 attribute (the title), while it should contain 2 attributes: the title and post ID.

    Please contact the plugin support and report this issue so they can fix it in a plugin update.

    As the theme modifies the title of WooCommerce products by appending a product price to the title, it hooks onto the_title filter, but expects 2 attributes. The plugin provides only 1 which in turn causes PHP error.

    I’ve applied temporary fix for this directly in your theme code. However, I can’t guarantee it will work 100% OK – please check all your WooCommerce products, if they display correct price in the product title (actually only in intro section, if you are not using intro in your products, you should be fine).

    After the plugin is updated and the issue is fixed, please reupload your theme again, overriding the edited files.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 10 posts - 1 through 10 (of 13 total)

You must be logged in to reply to this topic.