Home Forums Monument Valley Server status 500 with Awesome Support Plugin

Viewing 3 posts - 11 through 13 (of 13 total)
  • Author
    Posts
  • #21839
    wilderkaiser
    Participant

    Thank you so much!!

    Let me have a deeper view tomorrow! Ill be back to this to let you know my investigation.

    Have a nice evening!

    Greetz Joerg

    • This reply was modified 2 months, 3 weeks ago by Oliver Juhas. Reason: Making the post public as there is no sensitive information shared
    #21845
    wilderkaiser
    Participant

    Hello and Good morning,

    thanks again for serving me. I would like to add 2 considerations:

    1. why does not the error occur when using other themes?
    2. I missed a system email yesterday. Here the translated content:

    
    +++++++++++++++++++++++++++++++++++++++++++++++
    Since WordPress 5.2 there is a built-in function that detects when a plugin or theme causes a fatal error on your website, and therefore notifies you with this automated email.
    
    In this case, WordPress intercepted a bug in your Monument Valley theme.
    
    First, visit your website (..) and check for any visible issues. Next, visit the page where the error occurred (../wp-admin/post.php?post=142042&action=edit) and see if there are any visible issues.
    
    Please contact your hosting company for assistance in further investigation of this issue.
    
    If your website seems to be flawed and you can not access your dashboard as usual, WordPress now has a special "recovery mode". That way, you can securely log in to your dashboard and do more research.
    
    ...
    
    To protect your website, this link expires in 1 day. But do not worry: A new link will be sent to you by e-mail if the error recurs after the deadline.
    
    ERROR DETAILS:
    ====================
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 470 der Datei ../wp-content/themes/monument-valley/includes/plugins/woocommerce/class-woocommerce-loop.php verursacht. Fehlermeldung: Uncaught ArgumentCountError: Too few arguments to function Monument_Valley_WooCommerce_Loop::search_results_product_title(), 1 passed in ../wp-includes/class-wp-hook.php on line 286 and exactly 2 expected in ../wp-content/themes/monument-valley/includes/plugins/woocommerce/class-woocommerce-loop.php:470
    Stack trace:
    #0 ../wp-includes/class-wp-hook.php(286): Monument_Valley_WooCommerce_Loop::search_results_product_title('sdfgsfdgsdfgsdf...')
    #1 ../wp-includes/plugin.php(208): WP_Hook->apply_filters('sdfgsfdgsdfgsdf...', Array)
    #2 ../wp-content/plugins/awesome-support/includes/admin/metaboxes/user-profile.php(146): apply_filters('the_title', 'sdfgsfdgsdfgsdf...')
    #3 ../wp-content/plugins/awesome-support/includes/admin/functions-metaboxes.php(90): include_once('/var/www/
    
    +++++++++++++++++++++++++++++++++++++++++++++++
    

    so from this point of view there seems to be a problem with the theme. Can you let me know what happend?

    Kind regards

    Joerg

    • This reply was modified 2 months, 2 weeks ago by Oliver Juhas. Reason: Making the post public and removing sensitive information
    #21847
    Oliver Juhas
    Keymaster

    Hi Joerg,

    Please read my previous reply to you, I’ve actually explained all that in there.

    1. why does not the error occur when using other themes?

    Simply because other themes might not hook onto the_title filter, that’s all :)

    2. I missed a system email yesterday. Here the translated content:

    That email was probably sent during my debugging work or even before. I’ve actually adapted exactly the includes/plugins/woocommerce/class-woocommerce-loop.php file within the theme. In the theme it correctly uses 2 arguments. But as the plugin redefines native WordPress the_title filter hook incorrectly by not providing both arguments, it simply does not work correctly. The issue is within the plugin. Please read my previous reply where I’ve explained the situation (as non-technically as possible) and check all the links I’ve provided there to see for yourself.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 3 posts - 11 through 13 (of 13 total)
  • You must be logged in to reply to this topic.