short code doesn't work?

Home Forums Mustang short code doesn't work?

Viewing 10 posts - 1 through 10 (of 17 total)
  • Author
    Posts
  • #18362

    izumi
    Participant

    short code doesn't work?

    Resolved

    Hi,

    I use Mustang light since 2015.
    From beginning of this week, I found some character string above the master slider on my top page like this:

    [vc_row disable_container=”1″][vc_column width=”1/1″][/vc_column][/vc_row][vc_row][vc_column width=”5/7″]

    Firstly, I thought because of the Master Slider plugin, so, yesterday, I deleted this slider, but the situation became worse and worse…
    Now, all widget of right side placed below the topics and sizing as the page width.
    And above of the first widget, there is a haracter string:

    [/vc_column][vc_column width=”2/7″]

    and the end of the widget, another one:

    [/vc_column][/vc_row]

    I looked dashboard’s widget area, but it seems general sidebar is normal.
    Now I cannot restore the slider nor widget any more…
    I have no idea how I can do now.
    Please help me!

    Best

    Izumi

    #18368

    Oliver Juhas
    Keymaster

    Hi Izumi,

    First, please update your Mustang theme to the most recent version of 1.8.4.

    Also, please update all your plugins and WordPress to the most recent versions.

    If the issue still persists, please provide me with admin access to your website so I can check personally.

    Best regards,

    Oliver Juhas
    WebMan Design

    #18369

    Oliver Juhas
    Keymaster

    Also, the shortcodes displayed on your website belong to WPBakery Page Builder (previously called “Visual Composer”) and I can see the plugin is not active on the affected page. Please make sure you have the plugin installed and activated. Otherwise WordPress doesn’t know how to process those shortcodes.

    Best regards,

    Oliver Juhas
    WebMan Design

    #18386

    izumi
    Participant

    Hi Oliver,

    Thank you for your reply.
    I updated all, but nothing change, I see the same problem on the top page…
    I provide you the code here:

    [ ADMIN EDIT: ACCESS INFO REMOVED ]

    About the plugin ‘WPBakery Page Builder’, I didn’t installed it. However, I had no problem before.
    I found it but there is a lot of the same name plugin.
    Which one I have to install?

    • This reply was modified 4 months, 2 weeks ago by  Oliver Juhas. Reason: Making the reply public and deleting sensitive information, no longer needed
    #18389

    Oliver Juhas
    Keymaster

    Hi Izumi,

    Thank you for the login details. After information you’ve provided I do not need them, actually.

    Please note that those shortcodes are only processed with WPBakery Page Builder plugin (which is a paid plugin). The plugin was called Visual Composer in the past and that’s why there is vc_ in the shortcodes name.

    However, if you are not using the plugin, it is kind of mystery to me why the shortcodes were working for you before. Also, how did you inserted those shortcodes into your page? Have you find them somewhere online? I don’t think there is a way of inserting those into a page without Visual Composer/WPBakery Page Builder.

    Anyway, from what I can see, you are only using the shortcodes on your homepage. The current theme version is actually compatible with much better page builder plugin that does not use shortcodes, the Beaver Builder (you can also use the free lite version of the plugin). I no longer recommend using Visual Composer/WPBakery Page Builder plugin, Mustang keeps only backwards compatibility.

    But using any page builder and any shortcodes for your case would be overkill in my opinion. From what I can see, I think you want your homepage to have 2 columns of posts, a sidebar and a slideshow above them, correct? If so, here is what I suggest doing:

    1. Please remove the shortcodes from your homepage first, they are of no use now.
    2. Go to Settings → Reading and set “Your homepage displays” option to “Your latest posts”.
    3. Use solution from previous ticket to make your posts display in columns. (If you want to apply the layout globally, remove the .archive from the code. If you want to apply the layout on homepage only, replace .archive with .home. And surely, adapt the code to your needs.)
    4. To display slideshow on top of homepage, use this code in your child theme‘s functions.php file:
      function child_theme_slideshow() {
      	if ( is_front_page() ) {
      		echo '<div class="wrap-inner"><div class="pane twelve">'; // Remove this if not needed.
      		echo do_shortcode( '[your_slider_shortcode_here]' );
      		echo '</div></div>'; // Remove this if not needed.
      	}
      }
      add_action( 'tha_content_before', 'child_theme_slideshow' );

    This should do the trick for you ;)

    Best regards,

    Oliver Juhas
    WebMan Design

    #18396

    izumi
    Participant

    Hi Oliver,

    Thank you for your advice.
    It could be really useful but I am ‘null’ about short code.
    Am I capable to do this operation?
    Before doing your advise, I would like to know if I have to delete top pages short code (?).
    I attached the capture.
    Please advise.

    Best

    Izumi

    #18397

    izumi
    Participant

    Hi Oliver,

    I forgot to reply to you.
    Yes, I would like to have 2 columns of posts, a sidebar and a slideshow above them. And also, a footer. But actually, it seems that footer has no problem.
    As you see, above and below of the sidebar (actually placed after the posts), there are short codes.
    I can delete them using with your tips?
    Please advise.

    Best

    Izumi

    #18401

    Oliver Juhas
    Keymaster

    Hi Izumi,

    I can already see you are using a child theme on your website. So, just follow my instructions and you do not need to use any shortcodes. They are useless in your case.

    If you are not comfortable coding this on your own, please, try to ask some developer for help.

    Best regards,

    Oliver Juhas
    WebMan Design

    #18402

    izumi
    Participant

    Hi Oliver,

    I tried to do myself, however, firstly, I did as

    Settings → Reading and set “Your homepage displays” option to “Your latest posts”

    but nothing happened…there is no area to write the codes as you suggested on this page…
    What I have to do next?

    Also, I couldn’t find functions.php files.
    Where I have to look?

    I contacted the person who helped me to create my site, but this person ignored my message…I don’t know anyone who help me about this kind of problem.
    Please help me!

    Best

    Izumi

    #18403

    Oliver Juhas
    Keymaster

    Hi Izumi,

    Please understand that this is out of scope of free support I provide – please read terms of service. I can see what I can do if you provide me with admin access to your website.

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 10 posts - 1 through 10 (of 17 total)

You must be logged in to reply to this topic.