Submenu's submenu popping out on the right

Home Forums Mustang Submenu's submenu popping out on the right

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #19350

    Lana
    Participant

    Submenu's submenu popping out on the right

    Resolved

    Hey there! Have you noticed this support service is provided FREE of charge?
    If you like the speed and accuracy of resolutions, please consider supporting me with a small donation. Thank you

    Consider a donation →

    Hello Oliver!

    Could you please help me figure how to make submenu’s submenu appear on the right but not on the left? I am attaching a screenshot, just in case.

    Could you please also let me know if I’ll be able to upgrade to the paid version easily (I am using Mustang Lite at the moment but will need to upgrade soon)? Is my understanding is right and all I’ll have to do is installing Mustang and activating it?

    Thank you for your work, I am a huge fan of your themes!

    Best,
    Lana

    #19355

    Oliver Juhas
    Keymaster

    Hi Lana,

    Please try this custom CSS:

    .nav-main li li ul {
    	left: 115%;
    	right: auto;
    	-webkit-transition: opacity .2s, left .2s ease-in-out;
    	   -moz-transition: opacity .2s, left .2s ease-in-out;
    	    -ms-transition: opacity .2s, left .2s ease-in-out;
    	        transition: opacity .2s, left .2s ease-in-out;
    }
    
    .nav-main li li:hover > ul,
    .nav-main li li[aria-expanded="true"] > ul {
    	left: 100%;
    	right: auto;
    }

    If it does not work, please provide URL to your website so I can check personally.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19357

    Oliver Juhas
    Keymaster

    Also, thank you for being a huge fan of your themes :)

    As of upgrading to paid Mustang, yes, it is only a matter of installing the theme and activating it. Although, please note that due to how WordPress works, you might need to re-assign your widgets back to widget areas (the widgets settings will be kept and you can find the widgets in “Inactive Widgets” section in Appearance → Widgets) and also re-assign the navigational menus to correct locations.

    Best regards,

    Oliver Juhas
    WebMan Design

    #19368

    Lana
    Participant

    Thank you SO much for taking your time and helping me out! Now I see where I missed the point while trying to solve this problem on my own with css. Your solution works perfectly fine!

    Take care!

    All the best,
    Lana

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.