Translate : Continue reading (List child pages)

Home Forums Reykjavik Translate : Continue reading (List child pages)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17866

    Borne504
    Participant

    Translate : Continue reading (List child pages)

    Resolved

    Hello,

    Despite all my efforts with WPML, it seems that for the “List child pages” template, the text: Continue reading is not available for translation.

    Could you help me ?

    Thank you very much – Philippe

    #17867

    Oliver Juhas
    Keymaster

    Hi Philippe,

    I can assure you all texts in the theme is fully localizable. Together with the “Continue reading” text (here is also a PHP setup of the text).

    I have also tested localizing the theme with WPML and I can see the text in there too:

    Please check if you correctly localize the theme according to WPML instructions.

    However, I don’t think WPML is the correct way to localize WordPress themes and plugins. Please read the theme documentation info about localization. Maybe you could contribute your localization to others? :)

    WPML is a plugin to create a multilingual website, so, a website which displays in multiple languages, such as English, French and Spanish, for example.
    For single language websites it is pretty overkill. If you only want a website in French, for example, you should just localize the theme (and plugins) as described in theme documentation.

    Best regards,

    Oliver Juhas
    WebMan Design

    #17868

    Borne504
    Participant

    Thank you Olivier,

    I’m sorry but it still does not work. I even try with Poedit, nothing helps.

    The strongest thing in this case is that I tried to delete the file: link-more.php … and even without this file there is still the translation “Continue reading”.

    After checking on the demo page https://themedemos.webmandesign.eu/reykjavik/services/ (demo List child pages), I just noticed that no link points to the pages presented.

    Is there a bug?

    thank you very much

    #17869

    Borne504
    Participant

    Olivier,

    I just found a solution to the problem …

    Thanks again !!!

    #17870

    Oliver Juhas
    Keymaster

    Hi Philippe,

    Everything works for me perfectly fine when I test (translating to Slovak).

    Have you switched your WordPress to correct language in its Settings page maybe?

    With Poedit, have you uploaded the correctly created and named .mo file to correct location on your server (according to aforementioned instructions in theme documentation)?

    Please note that you should not delete any file from the theme! Anyway, after deleting the file, it should definitely remove the “Continue reading” text. So, it seems like you are using some caching solution? Make sure to flush the cache or disable it until you finish your website.

    There is no bug with “Continue reading” on “List child pages” page template. The link/button displays there only if a child page contains some content (and child pages don’t have any content set on demo website).

    Maybe you can try to disable plugins to see if there is a conflict?

    You can also provide admin access to your website so I can check personally.

    Best regards,

    Oliver Juhas
    WebMan Design

    #17871

    Oliver Juhas
    Keymaster

    Hi Philippe,

    Can you please share the solution you’ve found so others can benefit? Was it in misplaced/misnamed .mo file you’ve created with Poedit? Or maybe with some setting in WPML plugin?

    Best regards,

    Oliver Juhas
    WebMan Design

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.